OSPF跨区域实验

2018年7月15日23:37:50 发表评论 339 views

验拓扑:

OSPF跨区域实验

实验要求:
  • 按照实验拓扑图配置OSPF区域
  • 配置Area 1为NSSA no-summary区域
  • 允许添加一个额外的IP网段来实现这个目标

实验配置:

R1:
router ospf 1
network 192.168.12.1 0.0.0.0 area 0
R2:

router ospf 1
network 192.168.12.1 0.0.0.0 area 0
network 192.168.23.2 0.0.0.0 area 1
area 1 nssa no-summary
R3:
router ospf 1
network 192.168.23.3 0.0.0.0 area 1

 network 192.168.34.3 0.0.0.0 area 2
area 1 nssa no-summary
R4:
router ospf 1
network 192.168.34.4 0.0.0.0 area 2

解释:

  • 通常,每个区域都要与区域0相连接,如果中间存在一个非0的区域,则可以通过虚链路将区域0与本区域相连接
  • 但是由于区域1是属于存根区域,虚链路不能穿越存根区域,所以不能配置虚链路
  • 解决方法:在R2和R3之间创建隧道,并将隧道地址加入区域0或区域2

R2:
interface Tunnel0
 ip address 192.168.223.2 255.255.255.0
tunnel source FastEthernet0/0
tunnel destination 192.168.23.3

router ospf 1
network 192.168.223.2 0.0.0.0 area 0
R3:
interface Tunnel0
 ip address 192.168.223.3 255.255.255.0
tunnel source FastEthernet0/1
tunnel destination 192.168.23.2

router ospf 1 
 network 192.168.223.2 0.0.0.0 area 0

  • 这样的话,区域2就直接与区域0相连接,问题就能解决

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: